On January 14th 2020 Microsoft ended extended support for Windows Server 2008 and Windows Server 2008 R2. The oldest supported Windows Server version, Windows Server 2012, comes with Windows PowerShell 3.0 and .NET Framework 4.5.

The legacy variant of AWS Tools for PowerShell (AWSPowerShell) is currently compatible with Windows PowerShell 2.0 and .NET Framework 3.5. Starting May 1st 2020, AWS will require Windows PowerShell 3.0+ and .NET Framework 4.5+ as prerequisite for all new releases of AWSPowerShell. The existing versions of AWSPowerShell that are compatible with Windows PowerShell 2 and .NET Framework 3.5 will continue to be available for download from PowerShell Gallery, but will not be updated or supported.

What do I need to do?

  • If you are using modular or bundled variants of AWS Tools for PowerShell (AWS.Tools or AWSPowerShell.NetCore) , you are not impacted. No action is required.
  • If you are running a legacy variant of AWS Tools for PowerShell (AWSPowerShell) on Windows Server 2012 or higher, that already come with Windows PowerShell 3.0, or higher, and .NET Framework 4.5, or higher, you are not impacted. No action is required.
  • If you are running a legacy variant of AWS Tools for PowerShell (AWSPowerShell) on Windows Server 2008 or Windows Server 2008 R2 with Windows PowerShell 3.0, or higher, and .NET Framework 4.5, or higher, installed, you are not impacted, but please follow Microsoft guidelines on upgrading to the latest OS version
  • If you are running a legacy variant of AWS Tools for PowerShell (AWSPowerShell) on Windows Server 2008 or Windows Server 2008 R2 with Windows PowerShell 2.0, or .NET Framework 4.0, or lower, please upgrade to Microsoft Windows 2012 or higher.

from AWS Developer Blog: https://aws.amazon.com/blogs/developer/aws-is-updating-minimum-requirements-for-aws-tools-for-powershell-to-windows-powershell-3-0-and-net-framework-4-5/